This project is read-only.

How can I dial in?

Feb 6, 2014 at 5:32 PM
Dear All,

I have tried some of the examples. But I see the App starts a window appears wich says CTRL-C to exit, but I do not have any Idea how I have to dial in that the Programm will start. What do I have to configure? Which Extension do I have to Dial ?

Can you please give me a short advise!

Feb 6, 2014 at 6:29 PM
The samples are not really complete, and still very much a work in progress, however the redialer example should give a working example quite well.

To use it, you need to add a few lines to your extensions.conf, these lines may vary depending on your setup, but in general would be:

under the [default] section add:

exten => 7000,1,AGI(agi://<ip-of-your-windows-machine>/redialer)
exten => 7000,n,hangup()

7000 is the extension you want to dial to hit the AGI, this can be any number. replace <ip-of-your-windows-machine> with the IP that is running the example.

Also, you'll want to edit the example and replace:

public string securityPIN = "1234";
public string pstnTrunk = "ZAP/trunk1/";
public bool RecordCalls = true;

with the appropriate values.
Feb 6, 2014 at 8:12 PM
Thanks a lot, I will try this tomorrow!
Jun 21, 2015 at 10:30 AM
I'm aproaching to AsterNET, using the redial example, i am able to call the AGI in the way that skrusty wrote above.
I had to change the mp3 into wave failes to hear the voice recorded, but i cannot read the DTMF tone with GetData.

var pin = GetData("custom/redialer-enter-pin-number" );

I can hear the message,but after dial the digits and close with #, in asterisk CLI i can see that pin = -1

-- agi:// ReDialer
-- agi:// 1234
-- <SIP/201-00000017> Playing 'custom/redialer-enter-pin-number.slin' (language 'it')
-- agi:// PIN digitato:-1
-- <SIP/201-00000017>AGI Script agi:// completed, returning -1
After many test, i can say that after GetData the system doesn't answer in the right way.. i cannot call any AsterNET command.. for example

if i exec:
        var pin = GetData("custom/redialer-enter-pin-number" );
I can ear the first and the second message, but not the 3th, after exec completely the GetData the program continue but in the asterisk CLI the AGI disconnect with exception -1

Any Ideas?

Thanks Paolo
Jun 21, 2015 at 11:20 AM
I solved updating asterisk, i was using an old 1.6 for the tests, with version 11 all is ok!!